
IP Handsets and Third Party IP Gateways

Overview

This chapter discusses the integration of third-party VoIP devices, such as IP telephones and external IP gateways with TeleVantage. A number of third-party devices and solutions are surveyed. Configuration of several of these devices is covered.

I. Third Party VoIP Devices

II. VoIP Telephones

III. Third Party IP Gateways

IV. Back-to-back IP Gateway Configurations
Third Party VoIP Devices

In “IP Tie Lines”, we covered in depth how IP Link boards can be used with TeleVantage to connect calls between TeleVantage servers. In this case, each VoIP endpoint is a TeleVantage server.

TeleVantage can also be integrated with third party VoIP devices, such as VoIP telephones and IP gateways. Some configurations will require the TeleVantage server to have an IP Link board, others will not.

VoIP Telephones

A VoIP-enabled TeleVantage server (a server with an Intel Dialogic IP Link board) may connect calls from and to VoIP telephones that support H.323. For example, Polycom SoundPoint IP 400 and 500 telephones may be integrated with TeleVantage:
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Important: TeleVantage Client Call Monitor will display call appearances, but GUI call control features are disabled. Call control is accomplished by using the IP telephone’s keypad and feature buttons.

Third Party IP Gateways

A TeleVantage server with an IP link board may be integrated with an Intel NetStructure PBX-IP Media Gateway to support proprietary digital handsets from traditional PBX vendors. 

For example, eight Avaya MLX telephones could be interfaced with TeleVantage through a single Intel 4-wire digital PBX-IP Media Gateway:
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Important: As with VoIP Telephones, the TeleVantage Client Call Monitor will display call appearances, but will not allow for graphical call control. 

Back-to-back IP Gateway Configurations

Third party IP Gateway devices may also be used to extend the reach of TeleVantage. For example, station devices could be supported in a remote office by using two MultiTech MVP210 gateways to extend two station ports over a data network:
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This configuration does not require an IP Link board in the TeleVantage server. Proprietary codecs, such as NetCoder, may be used between the gateways.

Note: In this configuration, the TeleVantage Client Call Monitor behaves normally, allowing the use of all graphical call control features.

Network Requirements

The requirements for the underlying data networks will be as discussed in “Voice over IP in TeleVantage”.  If proprietary codecs are being used, check with the vendor for real-world bandwidth requirements. 

VoIP Telephones

Voice-over-IP based telephones may be used as an alternative to analog stations in a TeleVantage installation. 

IP telephones have certain advantages over traditional analog telephones:

· Sound quality may be equivalent to digital toll quality (sufficient network QoS, G.711 codec), even over long distances.

· The telephone may be positioned further away from the TeleVantage server than an analog station can – many miles versus less than one mile.

· An existing data network may be used as an alternative to running phone wire to a difficult location.

It is important to be aware of the following requirements and tradeoffs when using IP telephones:

· The graphical call control features built into TeleVantage Client do not work with IP telephones.

· IP telephones may require an FTP or TFTP server be present on the LAN to store configuration data.

· IP Link boards do not provide conference resources. The TeleVantage server must have at least one analog station board to provide those resources.

· For the duration that a VoIP call is connected, one shared voice resource is used to detect in-band signaling. 

Artisoft looks for compatible IP telephones that offer good features at an attractive price. One such telephone is the Polycom SoundPoint IP 500.

Polycom SoundPoint IP 500 Features

The Polycom SoundPoint IP 500 telephone has the following features and capabilities:

· Full duplex speakerphone – Superior quality and ease of use over half-duplex solutions.

· Two port 10/100 Ethernet switch – Support a user’s workstation and telephone with one Ethernet drop.

· Texas Instruments Orion chipset – DSP, processor and Ethernet switching designed specifically for VoIP.

· 13 programmable feature keys – Can be configured for use with TeleVantage.

· High contrast display with four soft buttons – For Caller ID and configuration display.

· Headset support – Supports Plantronics and GN Netcom headsets.

· H.323 support – Supports the G.711, G.723.1 and G.729 codecs

· PLAR support – Supports automatic login to a TeleVantage server.

The SoundPoint IP 400 telephone is similar, but offers only half-duplex speakerphone and an integrated 2-port Ethernet 10base-T hub.

Polycom has positioned this telephone to be usable with any system that embraces open VoIP standards. TeleVantage is a good example of such a system.

Note: although the Polycom SoundPoint IP telephones have a message waiting indicator lamp, TeleVantage does not yet support this feature with the SoundPoint IP phones.

Polycom SoundPoint IP 500 Configuration

SoundPoint IP telephones are configured from the front panel, and also via files downloaded by the telephone from an ftp server.

Basic Configuration

Basic telephone configuration is accomplished via the front panel. The IP stack must be configured, so that the phone can communicate over an IP data network. A Simple Network Time Protocol server should be specified, so that the telephone will keep accurate time without human intervention. A FTP server and login must also be entered, so the phone can download the rest of its configuration.
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FTP Configuration

The remaining configuration is stored as files on the telephone’s designated ftp server. 

Whenever the telephone is booted, it will attempt to log in to the ftp server and check to see if its master configuration file has been modified. If the telephone cannot login, or if the file has not been changed since the last check, the phone will boot up using its cached configuration. Otherwise, it will download the new master configuration file and all linked configuration files, then boot up with the new configuration.

This approach minimizes the quantity of information that needs to be entered into the telephones directly via keypad. A system administrator can update phone configurations by modifying files using a text or XML editor. 

Note: Microsoft XML Notepad 1.5 is the recommended editor for Polycom configuration files. XMLspy 5 Home Edition from Altova is another option.

A side benefit is that configuration templates may be provided by Artisoft to get the ball rolling on a SoundPoint IP implementation. These files are located in the \Polycom directory of the TeleVantage 5.0 Drivers CD. Copy these files to the ftp server you will be using to host the configuration files.

SoundPoint IP Configuration Files

For every telephone, the system administrator must create a master configuration file named after the MAC address of the telephone, of the syntax <MAC ID>.cfg.

For example:

If the telephone has a MAC address of 0004F208A31D, it will look for a file named to download named 0004f208a31d.cfg.

Note: The MAC address is printed on a sticker on the back of the telephone, and also can be displayed by pressing the “About” soft-button while the phone is booting.

If this file does not exist, the phone will download the default file, named 000000000000.cfg. 

This file is a template for customized master configuration files, and is structured as follows:
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· APP_FILE_PATH – This states the filename of the telephone’s firmware.

· CONFIG_FILES – This states the filenames of the linked configuration files the phone must also download: hmxuser1.cfg, hmx.cfg, func.cfg, and ipmid.cfg.

The linked configuration files can be classified into three groups:

· Files that don’t require modification – Use the Artisoft-provided func.cfg and ipmid.cfg files. These files contain low-level telephony and networking configuration settings. No changes to those files are needed.

· Files that do require modification – You must update the Artisoft-provided hmx.cfg file to list the IP address of your server’s IP Link board.

· Files that must be created for each user – Create and link a new hmxuserN.cfg and <MAC ID>.cfg file for each user’s telephone.

Note: The ipmid.cfg file defines the following order of preferences for codecs, which will work with TeleVantage default IP Span settings.

1. G.711 mu-Law

2. G.711 a-Law

3. G.729A, annex B

4. G.723.1 @ 6.3 kbps

Updating the hmx.cfg File

The hmx.cfg file contains Artisoft default parameters for key mapping, low-level VoIP protocol settings, and the phone’s internal debugging log. These parameters should not be edited.

This file also contains the parameter stating the IP address of your TeleVantage server’s IP Link card. This field is named feature.plar.address, and exists under the FEATURES group:
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Change the value for feature.plar.address to match the IP address of your IP Link board.

For example:

The IP Link board in our TeleVantage server has been given an IP address of 192.168.200.126. We open the hmx.cfg file using XML Notepad, change the value of feature.plar.address from “10.0.0.10” to “192.168.200.126”, and then save our change:
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Important: Do not make any changes to the voIpProt.server.address or voIpProt.server.alterserver.1.address fields in the VOIP group. You must leave those fields set to the default value of “0.0.0.0” for the system to behave properly.

Creating an hmxuserN.cfg File

The default hmxuser1.cfg file has the following structure:
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The following fields are user-specific, and should be changed for each file created:

· genDesc.name – The name of the telephone’s user

· genDesc.E164addr – The extension associated with the telephone

· plar.log.string – The PLAR connection string for the telephone, of the format *<Extension>*<Password>*
When creating these files, it is recommended that you name the files by extension.

For example:

We are deploying a Polycom SoundPoint IP telephone for Wendy Williams. Her extension is 326, and her password is 10203040. 

We create a file named hmxuser326.cfg as follows:
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To create this file, open hmxuser1.cfg using XML Notepad, change the key values, and then save the file as hmxuser326.cfg. 

[image: image1.png]Note: XML Notepad will create files with an .xml extension by default whenever files are saved. Whenever saving new or edited configuration files, select File > Save As… , then specify a Save as type of “All Files (*.*)”. 

Creating a <MAC ID>.cfg File

Now, create your master configuration file for the telephone so that the phone may download the correct linked configuration files.

For example:

The SoundPoint IP telephone for Wendy Williams has a MAC address of 0004F2123456. Using XML Notepad, we create a file for her telephone based on 000000000000.cfg as follows:
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Rebooting the Telephone

Once you have created the linked set of configuration files, reboot the telephone using one of the following methods:

· Power cycle the telephone.

· Simultaneously press the “Vol-“ key, the “Vol+” key, the “Hold” key and the middle feature key in the group of three above the hold key:
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The telephone will boot up with the new configuration. 

For further information on working with Polycom SoundPoint IP telephones, please see the SoundPoint IP 500 Server-based Configuration Guide .pdf, located in the \Polycom\IP 500 Bootrom subdirectory on the TeleVantage 5.0 Drivers CD.

TeleVantage User Configuration

Now that the telephone configuration is complete, add the associated user to your TeleVantage configuration as follows:

General Tab

Specify the user’s First name, Last name, Extension and Password under the General tab. For Station ID, specify “0”. If desired, enter descriptive information under Comments. The user Type must be “User”, not “ACD Workgroup user” or “IP Gateway user”:
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Phone Tab

If the user has a Station ID of “0”, special controls will be exposed on the Phone tab. These controls allow calls for the user’s extension to be sent to the IP telephone:
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· Check the box labeled Using a VoIP phone to access the other controls.

· Specify the ring duration. The default is 20 seconds. 

· Select a Phone type of “Polycom SoundPoint IP” from the drop down list. 

· Specify the Internet dialing service to use from the Call using drop down list.  

· Lastly, specify enter the IP address for the telephone in the Address field.

Security Tab

If you are using the automatic password expiry feature to force users to change their password after N days, you may wish to exclude SoundPoint IP users.

The global setting is visible under Tools > System Settings > Security:
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You may configure a user’s account so that their password never expires. Open their user account to the Security tab, then check the box labeled Password never expires:
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This will prevent you from needing to update the user’s hmxuserN.cfg file on a regular basis.

Finish Configuration

Configure the other user settings (Recordings, Notifications, etc.) as you would for any user account, then save your new user. If the configuration is correct on both sides, you will now be able to place calls from and to the IP telephone.

The Uniden UIP300 Telephone

At the time of this writing, Uniden is offering a special version of its UIP300 VoIP telephone with TeleVantage specific firmware. This telephone includes a half-duplex speakerphone, supports Artisoft PLAR, and provides a message waiting indicator lamp that works with TeleVantage. The phone does not have a built-in two-port switch, so a separate Ethernet drop is required.

The telephone’s TCP/IP and networking configuration is done via the keypad, and extended configuration is done via a web-based interface built into the telephone. 

Third Party IP Gateways

Although the term “IP Gateway” has a specific meaning in TeleVantage, the more general meaning is that an IP Gateway is a device that allows Voice-over-IP endpoints to communicate with traditional telephony endpoints. Any device that interfaces between switched telephone circuits and VoIP is an IP Gateway.

The Intel NetStructure PBX-IP Media Gateway

One such gateway is the Intel NetStructure PBX-IP Media Gateway. This device allows proprietary digital handsets to connect with Voice-over-IP devices.
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Proprietary digital handsets use 2B+D ISDN BRI circuits to communicate with their host PBXes. Proprietary signaling protocols are used to transmit button presses and light call appearance lights on the digital handsets.

The Intel PIMG supports physical connections for up to 8 such handsets, and can communicate with those handsets by emulating the proprietary signaling protocols used by vendors such as Avaya, Nortel, Mitel, and others. Different telephones may have a different physical layer interface (for example, 2-wire versus 4-wire). Consult with Intel on which PIMG model supports the handsets you intend to use.

In addition to simply connecting calls, the Intel PIMG can interpret button presses and translate to signaling understood by TeleVantage. 

For example, when the “Transfer” button is pressed on a particular telephone, the PIMG could send the “**1” digit sequence to TeleVantage.

In addition to the 8 RJ45 jacks used to connect handsets, the PIMG has a 10/100 Ethernet interface for connecting VoIP calls and a console/diagnostics port used to access its command line interface (for configuring low level settings and initial TCP/IP configuration).
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Note: As with Polycom SoundPoint IP telephones, TeleVantage Client does not support GUI based call control of phones connected to a PIMG. Call control would be accomplished using telephone commands and programmable buttons.

Intel PIMG Configuration Overview
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Once TCP/IP settings have been configured via the command line interface, the Intel PIMG may be monitored and configured via a user-friendly web-based interface. Point your browser to the unit’s IP address to log in:

This interface exposes most configuration parameters and provides system status information, such as software and hardware version information:
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Major configuration parameters are exposed in this interface, such as IP stack configuration, VoIP protocol and codec settings, which PBX the device is emulating, what model of handset is being connected to a particular port, and port to extension mapping.

Important: Some configuration parameters necessary for interoperation with TeleVantage must be entered via the command line interface, via Telnet or via a console port. These parameters should only need to be changed once when the device is first configured. See your system documentation for details.

By clicking the System link, we can see this PIMG is emulating a Lucent Merlin Magix system:
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And by selecting the Phone link, we can review port configurations for each of the 8 telephone ports:
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Port 1 is defined as extension 101, and port 2 is defined as extension 102. Both ports are configured to drive Lucent 4406D+ telephones, one of several options under Magix PBX emulation.

Note: When configuring a PIMG, bear in mind that certain configuration changes require a restart to become effective. All such fields are flagged with a “*” in the graphical interface.

TeleVantage User Configuration

Configuring a user account to work with a telephone attached to a PIMG is similar to setting up an account for a Polycom SoundPoint IP telephone. The only difference is in the phone tab settings.

Phone Tab

Configuration is as for a Polycom SoundPoint IP telephone, with the following exceptions:
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Select a Phone type of “Intel PBX-IP Media Gateway” from the drop down list. 

Enter the address of the telephone. To enter this information in the proper syntax, click the checkmark button to the left of the Address field. 

This will bring up a Check Internet Address dialog box:

[image: image22.png]Check Internet Address.

[z e 20737101

Itemnet address:

Flemole punber:

[192.168.200.73
i1

[ Show this window when an Intemet address is unclear

e | b





Enter the IP address of the PIMG under Internet address, and enter the extension of the phone on the PIMG under Remote number. This must match the Phone Name configured for the telephone on the PIMG’s phone tab. Then click OK. 

The address will be entered in the correct <IP Gateway Address>/<Extension> format:
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Once both the PIMG and the user account are configured, you will be able to place and receive calls from the telephone connected to the PIMG.

Back-to-Back IP Gateway Configurations

In many installations, there may be the need to support telephone handsets at a remote location. The remote location could be a different building on a corporate campus, the home office of a company officer, or a branch office in a different city.

One option for supporting remote telephones would be to install an IP Link board in the TeleVantage server, then deploy IP handsets at the remote locations. 

A second option would be to interface an analog IP gateway to station ports on the TeleVantage server, and then connect an IP gateway at the remote site to analog telephones. This option may be preferred if one or more of the following conditions applies:

· TeleVantage Client call control is required.

· TeleVantage server does not have a free PCI slot for an IP Link board.

· The end user’s device needs to be an inexpensive analog telephone (factory floor, insecure location, etc.).

· Only a few remote telephones must be supported.

In this scenario, TeleVantage just sees a station handset connected to a station port. The only difference from TeleVantage’s standpoint is that the Bellcore CLASS features available on the station telephone will be restricted to what is supported by the gateway devices.

For example:

Although a telephone connected at the far end supports Caller ID, Caller ID on Call Waiting and Message Waiting Indicator, one or more of these features may not be supported by the IP gateways in use.

Back-to-Back with MultiTech MultiVoIP Gateways

MultiTech’s MultiVoIP gateways are a popular choice for supporting remote stations with TeleVantage Client call control.

The MVP series of analog IP gateways includes three current models – The 2-port MVP210, the 4-port MVP410, and the 8-port MVP810. The MVP210 model is depicted below:
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The MVP analog gateways support two physical connectors for each logical port – an E&M jack for connecting E&M analog trunks, and an FXS/FXO jack for connecting loop start trunks or handsets. A 10/100 Ethernet port and an RJ45 console port are also present:
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A DB-9 to RJ-45 console cable is provided with the unit for interfacing with the COM port on a PC.

The FXS/FXO jacks are configurable in software for either FXO or FXS mode.

FXS (Foreign Exchange Station) – Emulates an analog trunk. Gateway ports connected to station devices must be configured for FXS mode. 

FXO (Foreign Exchange Office) – Emulates a handset. Gateway ports connected to a TeleVantage station port or to an analog CO trunk must be configured for FXO mode. 
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The MultiTech MVP gateways do not support any CLASS features for TeleVantage stations (no Caller ID, Caller ID on Call Waiting or Message Waiting Indicator). Stutter tone may not be heard at the remote extension, due to a short delay when connecting audio at the beginning of a call.

MultiTech MVP Configuration Overview

MultiTech gateways are initially configured via the console port using the MultiVOIP graphical configuration utility:
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Configuration tasks may be broken down into the following categories:
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TCP/IP Stack Configuration

To configure the TCP/IP settings for the Ethernet port, select Configuration > IP in the left hand tree view. Enter an IP address, netmask and gateway or enable DHCP. A static IP address is recommended.

H.323 & Codec Configuration

The MVP gateways support H.323 version 4 and fast start. The default settings for H.323, visible under Phone Book > Phone Book Configuration should be acceptable. If you change any of these settings, make sure to mirror the configuration on both sides.
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Codecs may be configured separately for each logical channel. The codec settings are visible under Configuration > Voice/Fax in the Coder section. The default coder is G.711 mu-Law, but may be changed to G.711 a-Law or G.729, or G.723.1, G.726, G.727 or NetCoder at one of several bit rates. Use the same codec for all channels on both gateways.

Note: MultiTech MVP gateways support a proprietary codec from AudioCodes known as NetCoder. According to AudioCodes, the NetCoder codec, at 9.6 Kbps, offers similar quality to G.711. Please see:

http://www.audiocodes.com/objects/NetCoder.pdf

Telephony Port Configuration

As TeleVantage uses loop start analog signaling, we will be using the MVP’s FXS/FXO jacks. Configuration options for the telephony ports are seen under Configuration > Interface, and may be set differently for each channel.
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FXO side configuration – Select FXO in the Interface section, then specify a ring count of 1 for FXO in the Ring Count section. This is the number of rings the port will wait for before accepting the call. A ring count of 0 is not supported. Repeat for each channel.

· FXS side configuration – Select FXS (Loop Start) in the Interface section.

Phone Book and Autodial Configuration

The goal for our configuration is simply to connect straight across the ports on each gateway bi-directionally. 

When TeleVantage rings a remote station port, we want that call to go into an FXO port on the local gateway and out the corresponding FXS port on the remote gateway. 

If a user goes off hook on a remote station, we want to connect that call through the FXS port on the remote gateway to the corresponding FXO port on the local gateway.

Configuration will consist of the following:

· Creating inbound phone book entries to bind extension numbers to ports.

· Creating outbound phone book entries to state how to reach target extensions on the remote system.

· Configuring automatic dialing so whenever a port goes off hook, it automatically dials the correct target extension without user interaction.

To plan for the configuration, it may help to assign extensions to each of the FXO/FXS ports on each of the gateways, as follows:
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To configure the logical connections:

1. Log into the first MVP Gateway.

2. Select Phone Book > Phone Book Modify > Inbound Phone Book > List Entries.
3. Click Add to create the first phone book entry. Enter “101” under Remove Prefix. For Channel Number, select “Channel 1”: 
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Then click OK. This will bind extension 101 to the first FXS/FXO port.

4. Add the second phone book entry, as follows, to bind extension 102 to the second FXS/FXO port:
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5. Select Phone Book > Phone Book Modify > Outbound Phone Book > List Entries.

6. Click Add to create the first outbound dialing rule. For Destination Pattern, enter “201”. For Total Digits, enter “3”. For IP Address, enter the IP address of the second MVP gateway:
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This states that extension 201 exists on the second MVP gateway.

7. Add a second outbound dialing rule, as follows, to state that extension 202 is also on the second MVP gateway:
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8. Select Configuration > Voice/Fax.

9. Under Voice/Fax Parameters, select “Channel 1”:
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10. Scroll down to view the Auto Call settings. Check Auto Call Enable and enter “201” under Phone Number:
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Whenever the first port goes off hook, the system will autodial extension 201.

11. Repeat steps 9 and 10 to configure the system to autodial extension 202 whenever the second port goes off hook. 

12. Log into the second MVP gateway, and repeat steps 1-11 with the following changes:

a. The inbound phone book entries are to reference extensions 201 and 202.

b. The outbound dialing rules state that extensions 101 and 102 exist on the first MVP gateway at 192.168.1.80.

c. Configure Channel 1 to autodial extension 101, and Channel 2 to autodial extension 202.

Once both sides are configured, the system will automatically dial the correct port on the remote gateway whenever a local port goes off hook. Calls may be made and taken on the remote station as if it is connected to TeleVantage with a straight piece of wire. 

Back-to-Back with AudioCodes MediaPack Gateways

AudioCodes offers a similar line of products, their MediaPack analog IP gateways. Models are available with 2 to 8 ports, in FXS or FXO, and with 24 ports, FXS only.

These analog IP gateways offer certain advantages and tradeoffs.

Advantages

· AudioCodes gateways support Caller ID Type I. 

· AudioCodes MediaPack gateways may be less expensive per port.

· Configuration is via HTTP, and does not require special software.

Tradeoffs

· Telephony ports are not software configurable – you must choose between FXS and FXO gateway models at the time of purchase.

· MediaPack gateways do not support E&M analog signaling. This does not effect integration with TeleVantage. 

As with the MultiVoIP MVP Gateways, AudioCodes MediaPack gateways do not support Caller ID on Call Waiting (Caller ID type II) or message waiting indicator. Due to a delay in setting up the initial audio connection, stutter dial tone may not be heard.

At the time of writing, AudioCodes is planning on marketing its MediaPack gateways to the TeleVantage channel as a cost-effective alternative to other analog IP Gateway devices. 

Summary

In this chapter, we discussed a number of third-party VoIP devices and stated how they can be integrated with a TeleVantage system. IP telephones discussed include the SoundPoint IP 400 and 500 models, and the Uniden UIP300 telephone. We discussed using the Intel NetStructure PBX-IP Media Gateway with a VoIP enabled TeleVantage server to integrate proprietary digital handsets with TeleVantage. We also examined two families of analog IP gateway devices, and showed how they could be used to extend the reach of TeleVantage station ports while preserving TeleVantage Client call control capability.

Questions

1. What are the advantages of the Polycom SoundPoint IP 500 over the IP 400?

2. What Polycom SoundPoint IP configuration file configures function key mapping?

3. How many digital phones can a single Intel PIMG support?

4. Do the extensions assigned to FXS/FXO ports on a MultiVoIP analog IP gateway need to match the user’s TeleVantage extension? Why or why not?

5. When a call rings a station port connected to a properly configured MultiVoIP analog IP gateway, what sequence of events causes the call to ring the remote station device? Trace the logical connection between the analog IP gateways.
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